Welcome, Guest
Username: Password: Remember me

TOPIC: Problem with array filter

Problem with array filter 3 years 6 days ago #69340

  • schick00
  • schick00's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hello all,

I've run into a behavior I don't recall seeing before. I have a multiple choice question with check boxes. It is followed by an array question that has the same list of sub questions with identical codes. I set it up to filter the questions in the second question by which items are checked in the first.

I have done with before with great success. In this instance it works as long as at least one item is checked on the list. If nothing is checked, all the items show up in the second questions instead of none, which is my expectation.

Have I misunderstood the use of an array filter? Am I missing something?

Thanks,
Scot

Windows 7
Apache 2.2
PHP 5.3
MySQL 5.5
Version 1.91+ Build 11163
The administrator has disabled public write access.

Re: Problem with array filter 3 years 6 days ago #69352

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
Please test if the problem still exists at the latest release. If so please open a ticket at the bugtracker and...
  1. Give as much information as possible
  2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.
  3. Provide step-by-step instructions how to reproduce the problem.
  4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Problem with array filter 3 years 6 days ago #69363

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4358
  • Thank you received: 826
  • Karma: 381
You can use conditions to only show the array question if at least one option in the multi-options is selected.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Problem with array filter 3 years 5 days ago #69427

  • schick00
  • schick00's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Thanks Tony. I never thought about going at it from that direction.

Mazi, I'll try the newer build and see if I see the same behavior. Thanks for the help. The survey is kind of sensitive, but if I am still have that problem I'll try it with a new survey I can send.

Scot
The administrator has disabled public write access.

Re: Problem with array filter 3 years 2 days ago #69510

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5423
  • Thank you received: 307
  • Karma: 252
When reporting bugs you can set the ticket to be private so only our developers can look at the attached survey.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.120 seconds
Donation Image