Welcome, Guest
Username: Password: Remember me

TOPIC: Array Filter data was not captured

Array Filter data was not captured 3 years 1 month ago #67296

  • sivajik
  • sivajik's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Currently I have an one survey with Array Filter option, When I take the survey, the programming seems to work fine...but for some reason the data was not captured for that question (I just look at responses and it says that all responses are "non completed or not displayed", even though anyone who chose any choice except Never received this question). Do I need to change anything in the settings to see the data in response? Please do the needful.

For example I have created one test survey with array filter option.

survey.rodale.com/admin/admin.php?sid=38732#
The administrator has disabled public write access.

Re: Array Filter data was not captured 3 years 1 month ago #67297

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2956
  • Thank you received: 380
  • Karma: 124
The link doesn't work.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: Array Filter data was not captured 3 years 1 month ago #67308

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5425
  • Thank you received: 307
  • Karma: 252
1. The survey seems to be broken, I see no answer options at survey.rodale.com/index.php?sid=38732#

2. Which Limesurvey version do you use?

3. Can you attach the survey here for testing?

4. Did you modify the template?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Array Filter data was not captured 3 years 1 month ago #67326

  • sivajik
  • sivajik's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
I am sorry, here's the attachment of my test survey.

I am using Version 1.87+ (8406)

No I didn't modify anything in the template.

File Attachment:

File Name: limesurvey_survey_38732.csv
File Size: 5 KB
The administrator has disabled public write access.

Re: Array Filter data was not captured 3 years 1 month ago #67328

  • Mazi
  • Mazi's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 5425
  • Thank you received: 307
  • Karma: 252
I can reproduce the problem at the latest build. I get a warning at testing:
Notice: Undefined index: 38732X26X399 in C:\xampp\htdocs\limeSOURCE\limesurvey_current\common_functions.php on line 4661

Your survey somehow looks broken to me. Please try to rebuild those two questions and let me know if the error still shows up.

Attached is a test survey which supports different array filter settings:

File Attachment:

File Name: Limesurvey_sample_survey__Array_Filter_and_Exclusion.lss
File Size: 46 KB

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.102 seconds
Donation Image