Welcome, Guest
Username: Password: Remember me

TOPIC: Problem with file upload question

Problem with file upload question 2 years 10 months ago #66906

  • Bjup
  • Bjup's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi,

I have a problem with the file upload quesion type in one of my surveys. Limesurvey keeps giving the message that files are too large to upload while this is not the case. I've set max file size to larger and larger sizes (currently at 48000 KB), but when uploading a file larger than 2 MB I still get the message that the file is too large.
Can anyone help me fix this?
The administrator has disabled public write access.

Re: Problem with file upload question 2 years 10 months ago #66907

  • Eddie_V
  • Eddie_V's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 42
  • Thank you received: 2
  • Karma: 1
that is the default setting for php (2MB)

you can change that in your php.ini, there is a setting there:

; Maximum allowed size for uploaded files.
upload_max_filesize = 2M

change that to whatever size you want.

be aware tho that there are probably more then one php.ini's on your server.
there is one for each webserver installed eg. Apache2 and one for commandline PHP. You need to change the one for the webserver you use. you can find the php.ini's on you server by typing "locate php.ini" on the commandline

If you dont have access to the server you need to contact the system administrator and ask them to do it
Last Edit: 2 years 10 months ago by Eddie_V.
The administrator has disabled public write access.

Re: Problem with file upload question 2 years 10 months ago #66909

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5324
  • Thank you received: 293
  • Karma: 248
Thanks a lot for this helpful instructions. Can you add this to our wiki so that other users can benefit from your solution, too? Would be great!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.119 seconds
Donation Image