Welcome, Guest
Username: Password: Remember me

TOPIC: Export to DOC - problem with encoding, assessment

Export to DOC - problem with encoding, assessment 3 years 1 month ago #61988

  • petrahele
  • petrahele's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Hi,
I wanted to export the data from my survey, but after opening the DOC file in OpenOffice.org Writer I get incorrectly displayed national characters. I do not know whether I have bad encoding set in Limesurvey or where is the problem. I know that my native language (Czech) uses UTF-8 or CP1250 encoding.
did anybody have similar problem? Any advice appreciated :(

Second, is it possible to include the final score in the text export? I have there all the answers but not the score for whole test and the assessment.

thanks
latest Limesurvey on localhost, Ubuntu 10.04 (lucid), kernel 2.6.32-22-generic, Gnome 2.30.0, hardware: HP 550 laptop, 1GB RAM, Intel Celeron, Intel graphics
Last Edit: 3 years 1 month ago by petrahele.
The administrator has disabled public write access.

Re: Export to DOC - problem with encoding, assessment 3 years 1 month ago #61997

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4072
  • Thank you received: 748
  • Karma: 341
Regarding question 2, you could populate a hidden question with the assessment_CURRENT_TOTAL.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Export to DOC - problem with encoding, assessment 3 years 1 month ago #62056

  • petrahele
  • petrahele's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 4
  • Karma: 0
Thanks Tony,
however, maybe I am too stupid to understand the structure. My survey has url:
MMSE (Mini Mental State Exam) (ID 42176)
http://localhost/limesurvey/index.php?sid=42176&lang=cs

I read all the links about end url etc. I activated the automatic url loading and then tried:
http://localhost/limesurvey/index.php?sid=42176&lang=cs&{assessment_CURRENT_TOTAL}
and
http://localhost/limesurvey/index.php?sid=42176&lang=cs&var1={assessment_CURRENT_TOTAL}
and also
{assessment_CURRENT_TOTAL}

first two ones redirect me back to the beginning of the survey and third one results in error message (404 Not Found).

could you give me more detailed advice? I think that after one survey with working assessment I will be able to use it in others too. :silly:

thanks
latest Limesurvey on localhost, Ubuntu 10.04 (lucid), kernel 2.6.32-22-generic, Gnome 2.30.0, hardware: HP 550 laptop, 1GB RAM, Intel Celeron, Intel graphics
The administrator has disabled public write access.

Re: Export to DOC - problem with encoding, assessment 3 years 1 month ago #62098

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4072
  • Thank you received: 748
  • Karma: 341
1) Does the problem occur in MS Word? Can you attach a sample file?

2) You can use JavaScript and {assessment_CURRENT_TOTAL} to load a hidden question on the last page with the assessment total.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.123 seconds
Donation Image