Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: I can't show question numbers or codes ?

I can't show question numbers or codes ? 3 years 4 months ago #61228

  • persmash
  • persmash's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Hi. I've two problems with limesurvey.
First, I can't show question number or codes in survey. I was using 1.91 RC4. I searched for this issue and find a suggestion to do update.
I've updated 1.91 Build 10089. The problem didn't solved. And there is a text right above in admin panel that always says new update available 1.91 Update 10089. I'm also using this version. What is this update? And one more thing, I can't use ComfortUpdate. The server is always busy.

As a result, I need to show question number or codes immediately. The survey is waiting for this to be released.
Thanks in advance...
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61232

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2715
  • Thank you received: 331
  • Karma: 121
What do you mean with "you can't show question number or codes in survey"?

You want them to appear in your survey, like:

"Question1: This is the question text" instead of just "This is the question text"?

You probably need to change/add that in your template. What template are you using?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61243

  • persmash
  • persmash's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Yes. I mean exactly what you said.
I'm using default template.
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61260

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4206
  • Thank you received: 790
  • Karma: 360
Did you set "Show group name and/or group description" in the Presentation &; navigation tab?

Capture2_2011-05-24.JPG
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61302

  • persmash
  • persmash's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
Yes. I made it.
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61313

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4206
  • Thank you received: 790
  • Karma: 360
Could you please post the contents of your question.pstpl file and maybe a link to a test survey?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61315

  • persmash
  • persmash's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
I'm so sorry. It is a private survey.
But I can send you question.pstpl code.
Here it is:
<div {QUESTION_ESSENTIALS} class="{QUESTION_CLASS}{QUESTION_MAN_CLASS}{QUESTION_INPUT_ERROR_CLASS}">
	<table class="question-wrapper">
		<tr>
			<td class="questiontext">
				<span class="asterisk">{QUESTION_MANDATORY}</span>{QUESTION_TEXT}<br /><span class="questionhelp">{QUESTION_HELP}</span>
				{QUESTION_MAN_MESSAGE}
				{QUESTION_VALID_MESSAGE}
			</td>
		</tr>
		<tr>
			<td class="answer">
				{ANSWER}
			</td>
		</tr>
		<tr>
			<td class="survey-question-help">
				{QUESTIONHELP}
			</td>
		</tr>
	</table>
</div>
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61316

  • persmash
  • persmash's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
I've solved the problem.
When I updated my question.pstpl file with a new version, the problem is solved.
Thank you very much...
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61318

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 4206
  • Thank you received: 790
  • Karma: 360
Cool.

For other users - question.pstpl must contain the {QUESTION_NUMBER} and/or {QUESTION_CODE} placeholders.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: I can't show question numbers or codes ? 3 years 4 months ago #61320

  • persmash
  • persmash's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 12
  • Karma: 0
I need to ask you something more.
As I said before, I've updated my LimeSurvey but there is some errors.
If you can get in touch with me, I want to give you admin username and password, and I want you to check my settings if you are available.
Thanks in advance...
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.168 seconds
Donation Image