Welcome, Guest
Username: Password: Remember me

TOPIC: Loosing email formatting

Re: Loosing email formatting 3 years 7 months ago #55619

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
waitz wrote:
I have limesurvey installed in a folder in the same area as a joomla site. Is there a possibility that there is a javascript or jquery conflict because of that..?
That might cause the problem but it's hard to say.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55623

  • waitz
  • waitz's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
Urghh..... I enabled debugging in the config file, but it doesn't show in the backend. Double urghh.... What to do...
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55632

  • c_schmitz
  • c_schmitz's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 779
  • Thank you received: 111
  • Karma: 92
Under any chances, could it be that you copied the Welcome text from another source, like a Word document?
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55633

  • waitz
  • waitz's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
I am afraid now :(

The survey was exported from 1.86 and imported to 1.90, and it is clean html in the formattings. And if create new basic formattings in 1.90, like a paragraph, it looses all the formatting after save, and it cuts it off after a certain length.

And the strange thing is that I get the same errors in 1.86 also....

This is turning into a bit of a crisis, because I can´t use the survey if I don´t manage to find the cause...
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55634

  • c_schmitz
  • c_schmitz's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 779
  • Thank you received: 111
  • Karma: 92
Can you attach that survey here?
Support us, too. Donate to the LimeSurvey project and help keep us going!
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55644

  • waitz
  • waitz's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
Hi C

Thanks. I attach the same survey twice:
-The csv file is the original survey with formatting of the welcome message intact
-The lss file is the same survey after I opened the welcome message for the survey and saved it again.

I PM you the password for the zip file.

File Attachment:

File Name: survey.zip
File Size: 30 KB
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
Last Edit: 3 years 7 months ago by waitz.
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55648

  • waitz
  • waitz's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
I did a test: I copied all the limesurvey files to a local wamp server, ran the installation script, and opened limesurvey admin there. Everything is ok.

So I deleted the db on our webserver, and ran the installation script again, but I get the same errors as before. So it must be something on the webserver that causes it, right? But what.....?
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55653

  • c_schmitz
  • c_schmitz's Avatar
  • NOW ONLINE
  • LimeSurvey Team
  • Posts: 779
  • Thank you received: 111
  • Karma: 92
IMporting and saving the welcome text works just fine here - so it really is something with your hosting. I guess some server-side filter is removing the HTML - but is is just a guess. Never have seen something like this before.

You should use another hosting or use LimeService to create online surveys: www.LimeService.com
Support us, too. Donate to the LimeSurvey project and help keep us going!
Last Edit: 3 years 7 months ago by c_schmitz.
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55658

  • waitz
  • waitz's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 171
  • Thank you received: 1
  • Karma: 3
Thanks, I will contact the host. We have a tuned up host for Joomla, so I will try to find a solution before I change the host.
Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
The administrator has disabled public write access.

Re: Loosing email formatting 3 years 7 months ago #55659

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5325
  • Thank you received: 296
  • Karma: 249
Once you have solved this issue please report back so that other users will benefit from your solution, too.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.118 seconds
Donation Image