Welcome, Guest
Username: Password: Remember me

TOPIC: Blank screen after installation

Blank screen after installation 5 months 1 week ago #108618

I have been having trouble installing LimeSurvey, I believe I was on the final step of the installation (after populating the database) and the page remained blank. I do not know how to access my "Web server log" but the closest problem to the one I was having seemed to be this:

manual.limesurvey.org/Installation_FAQ#B...ing_the_Install_page

When I try to access "your.domain.com/limesurvey/admin/admin.php", the address updates to "your.domain.com/limesurvey/index.php/admin" and the page is blank.

The fix suggested is as follows:
"This is probably an incorrect setting for $rooturl or $rootdir in config.php. In particular, config.php attempts to set $rootdir correctly by calling dirname('''FILE''') and while this usually works, it can be upset when LimeSurvey is installed in a user's home or public_html directory and the home directory is mounted over NFS. Try setting $rootdir manually, and in particular, while your shell or pwd command may show a path like "/disks/hostname/home/username/public_html/limesurvey", try using "/home/username/public_html/limesurvey"."

I found this very confusing. I found more than one config.php but I guessed the one I was after was in limesurvey/application/config/config.php

I downloaded this and opened in an editor. I have no idea what to do with this, I don't see any "$rooturl" or "$rootdir".

I don't know what "home directory is mounted over NFS" means but limesurvey is definitely located in "public_html".

I am now doubting I am even going down the right track trying to fix this. I might try a re-install first but I will have to delete all the files and wait an hour for filezilla to upload them all again.

The alternative is to make the survey myself which I can do using mysql and basic php & html but I was hoping this would be easier and more fun.
The administrator has disabled public write access.

Blank screen after installation 5 months 1 week ago #108625

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2851
  • Thank you received: 358
  • Karma: 124
There are quite a few things regarding this in the forum. I remember that just last week someone was reporting about his host had solved a similar problem.

What PHP version do you run on? Which LS version? What kind of server?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Blank screen after installation 5 months 1 week ago #108627

MYSQL:
Server version: 5.1.73-cll - MySQL Community Server (GPLv2)

This is under Web Server:
Database client version: libmysql - 5.0.96

what is LS? (I just realized this is LimeSurvey right? :lol: )
I am using the latest LimeSurvey download:
limesurvey205plus-build140502

Searching for related posts now..

Thanks
Last Edit: 5 months 1 week ago by JeffNevington. Reason: because I am slow
The administrator has disabled public write access.

It's working now 5 months 1 week ago #108630

Okay so I should have done this before posting really. Deleted it, re-installed from the start and now it is working.

2 things I changed:

1:
previously when uploading with ftp using filezilla I got 2-3 "overwrite?" messages, it looked like the same file just overwriting the same file. I thought it was a bit strange but I let it do its thing.

This time I uploaded the .zip file and then extracted it on the server. Whether this made a difference or not I do not know, I do know it was 1000x faster though!

2:
I used "777" instead of "755" for the directory permissions (again, don't know if it made a difference)

Thanks,

Jeff
The administrator has disabled public write access.

It's working now 5 months 1 week ago #108631

  • holch
  • holch's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 2851
  • Thank you received: 358
  • Karma: 124
Great to hear it is working. And yest, uploading the zip file instead of all files is a lot quicker. But this is the same case even on your local drives, a lot of small files or a few big files, even if the overall size is the same, the big files will be transferred a lot quicker (less overhead).

Yes, LS = Limesurvey

Sometimes files are missing from the installation, this might have been your case. With FTP chances are high that this can happen. With a single file not so much.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.100 seconds
Donation Image