Welcome, Guest
Username: Password: Remember me

TOPIC: Submission of first page of survey not processed

Submission of first page of survey not processed 8 months 2 weeks ago #104570

  • Matherion
  • Matherion's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
This is a weird error that I've encountered since LS started using pretty URLs. The error is the following.

When starting a survey and submitting the first page, this submission is not processed, and the same first page is loaded again.

For example, when using a welcome page, clicking 'next' just shows the welcome page again. Then, once you clicked 'next' again, the next page shows, and the survey proceeds for the rest as expected.

Another example: if you disable the welcome page, the first page of the survey immediately shows. When you complete this, and click 'next', the same page reloads. All form fields are emptied, and a modal popup is shown saying roughly (translating from Dutch) "Use the navigation buttons or the index. Possibly you used the back-button in the browser." (original: "Gebruik de navigatieknoppen of de index. Mogelijk heeft u de terug-knop van de browser gebruikt."). When completing the form again and clicking 'next' again, the survey again proceeds normally.

You can test this out yourself using partypanel.nl/ls/index.php/865253/lang-nl-informal

This behavior replicated across browsers and operating systems (at least, as far as I've seen so far - at the moment, I can verify it for the URL I provide above with Chrome, FF and IE on Win8.1).

In previous versions of LS (before using the GET vars became obsolete; 2.05 or so?), this behavior could be avoided by using GET variables to specify survey id etc - however, in the recent versions of LS, this is no longer possible, making this problem a bit more urgent.

I encountered this problem on two different servers (one on a dedicated server run by zylon.nl; another on a VPS (virtual private server) run by transip.nl. Both servers run linux, with run-of-the-mill up-to-dateish versions of PHP and MySQL. The most recent LS installation is version 2.05+ Build 140131 on partypanel.nl (the version I link to above). On this server, the VPS, I made phpinfo() available at partypanel.nl/phpinfo.php

Carsten and I tried to debug this yesterday evening (around 2100, but this part is not in the irc log unfortunately). At some point the theory was that perhaps something goes wrong with the sessions, and I changed php.ini so that the sessions are now stored in "/home/partypanel/sessions". The sessions work properly now, and this doesn't seem to be the problem. In fact, on my other server (one of the domains is dosurvey.eu, e.g. dosurvey.eu/ls200/), many other systems run without problems (e.g. Drupal, Wordpress, Question2Answer, etc), even though these all use session variables as well.

I have no clue what is going wrong, but I definitely need to resolve this now that using GET vars to avoid the problem is no longer an option. Also, given the fact that this doesn't seem to be due to an idiosyncratic server configuration (since the same problem occurs on two different servers), I can imagine it would also be beneficial for LS to at least figure out what is happening here - i.e. how this behavior is even possible in the first place.

Any help, tips to help troubleshooting/debugging, suggestions for things to test re: server settings or .htaccess settings, are much appreciated!
The administrator has disabled public write access.

Submission of first page of survey not processed 8 months 2 weeks ago #104572

  • Matherion
  • Matherion's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
PS: .htaccess is processed by Apache. I checked this by commenting out all contents and adding some bullshit (in fact, I literally added 'some bullshit' :-)), which resulted in the expected Internal Server Error.

Currently, I have this in the .htaccess:
<IfModule mod_rewrite.c>
    RewriteEngine on
 
    # if a directory or a file exists, use it directly
    RewriteCond %{REQUEST_FILENAME} !-f
 
    # otherwise forward it to index.php
    RewriteRule . index.php
</IfModule>
# General setting to properly handle LimeSurvey paths
AcceptPathInfo on

(i.e. the original file, with AcceptPathInfo uncommented).

However, I can comment or uncomment any line - it makes no difference. LimeSurvey behaves identical . . . Is this perhaps some useful information to anybody?
The administrator has disabled public write access.

Submission of first page of survey not processed 8 months 2 weeks ago #104579

  • Matherion
  • Matherion's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
This also relates to www.limesurvey.org/en/forum/installation...ed-after-2-05-update and to the bug report bugs.limesurvey.org/view.php?id=8586 that's linked to from that forum post.

However, the suggestion, i.e. using an 'r' GET var, doesn't seem to work, assuming it should be ?r=survey/index&sid=99999&lang=en (e.g.) . . .
The administrator has disabled public write access.

Submission of first page of survey not processed 8 months 2 weeks ago #104726

  • Matherion
  • Matherion's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 18
  • Karma: 0
This turned out to be because of an old custom theme! Apparently, smth changed, don't know what yet - I'll hopefully find out over the next few days/weeks. But in case anybody else has the same problem; try using another theme and see whether that solves it!

(although, I have to admit, I also switched to the newest build, Version 2.05+ Build 140204, while testing, so that could also be it . . .) If I figure out what exactly the problem was, I'll let you know! :-)
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.150 seconds
Donation Image