Welcome, Guest
Username: Password: Remember me

TOPIC: Polish special characters in open answers

Polish special characters in open answers 5 months 4 days ago #108999

  • PerOlander
  • PerOlander's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Hi,

We are running a lot of surveys in Polish, and whenever there is an open text, or "other" with a sub-string, limesurvey doesnt seem to handle the Polish special characters correct.

they are displayed as "?", both when exporting to excel, and when previewing the file directly in limesurvey.

is there any sort of setting where I can change this?

Best Regards,
Per Olander
The administrator has disabled public write access.

Polish special characters in open answers 5 months 4 days ago #109027

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Hi,

LS are utf8 ready, what is your LimeSurvey version ?

Did yountry to open the file with LibreOffice.

Denis
The administrator has disabled public write access.

Polish special characters in open answers 5 months 4 days ago #109031

  • PerOlander
  • PerOlander's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
Hi Denis,

thanks for you answer!

we run Version 2.00+ Build 131206

I have not tried LibreOffice yet, I will do - but a solution for Excel is appreciated, since it is part of a bigger VBA setup.
however, the characters are also not showing correctly when previewed in LS, so it doesnt seem to be an Excel issue? see picture:
www.dropbox.com/s/2iw63ohb1lv0206/LS_polish_characters.png
The administrator has disabled public write access.

Polish special characters in open answers 5 months 4 days ago #109035

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
Can you provide a little lsa file ?

I think it's clean on LS 2.00 too.
The administrator has disabled public write access.

Polish special characters in open answers 5 months 4 days ago #109037

  • PerOlander
  • PerOlander's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
I am off for a meating now - within the next 3 hours, I will make a demo-survey with some dummy data that I can give you an export file for - I will export both the csv and excel version.

thanks again!
The administrator has disabled public write access.

Polish special characters in open answers 5 months 4 days ago #109039

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
No,

Export the survey archive (lsa file), answers are inside.

Denis
The administrator has disabled public write access.

Polish special characters in open answers 5 months 3 days ago #109048

  • PerOlander
  • PerOlander's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
I have taken this string, and entered as an answer in the survey:
AaĄąBbCcĆćDdEeĘęFfGgHhIiJjKkLlŁłMmNnŃńOoÓóPpRrSsŚśTtUuWwYyZzŹźŻż
letters are taken from:
en.wikipedia.org/wiki/Polish_alphabet

lsa file:
www.dropbox.com/s/rgmwj1pql7u4wqt/survey_archive_495263.lsa
The administrator has disabled public write access.

Polish special characters in open answers 5 months 3 days ago #109050

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6451
  • Thank you received: 844
  • Karma: 249
OK,

For the aready set answers : same think for me, but an new answer is clean (see the screenshot).

Then surely something with the DB.
What is your DB ?
Can you look if your DB server have utf8 activated ? The lime_survey_XXX must be in utf8_unicode_ci.

PS: LimeSUrvey since 1.81 (or before ?) is used in chinese , arabic .... etc ... then polish is more easy ;)
Attachments:
Last Edit: 5 months 3 days ago by DenisChenu.
The administrator has disabled public write access.

Polish special characters in open answers 5 months 3 days ago #109051

  • PerOlander
  • PerOlander's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
thanks - we dont host the server ourselves, but I will forward this whole thread to those who do - hopefully this will solve it!
The administrator has disabled public write access.

Polish special characters in open answers 5 months 3 days ago #109058

  • PerOlander
  • PerOlander's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 9
  • Karma: 0
for some reason it was set as latin, way back in time when the server was set up...
changing that to utf8 solved the problem, so thanks for your help!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.108 seconds
Donation Image