Welcome, Guest
Username: Password: Remember me

TOPIC: why cannot upload img to question?

why cannot upload img to question? 9 months 4 weeks ago #105254

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6658
  • Thank you received: 887
  • Karma: 263
Hi,

Without do some tracevar/var_export/console.log i really have no idea what's happen for you.

Sorry
The administrator has disabled public write access.

why cannot upload img to question? 9 months 4 weeks ago #105268

  • iscar
  • iscar's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 216
  • Thank you received: 1
  • Karma: 0
thanks for your instruction.
i am trying to use firebug,but don't understand how to use
tracevar/var_export/console.log
shall i input them after >>>?

1_2014-02-19.jpg
The administrator has disabled public write access.

why cannot upload img to question? 9 months 4 weeks ago #105269

  • DenisChenu
  • DenisChenu's Avatar
  • OFFLINE
  • Moderator Lime
  • Posts: 6658
  • Thank you received: 887
  • Karma: 263
iscar wrote:
thanks for your instruction.
i am trying to use firebug,but don't understand how to use
tracevar/var_export/console.log
shall i input them after >>>?
No, sorry , not clear here.

I just say : without hacking code to put some test here or here, or elsewhere ....

A bad bebugging method, a way to find where it's buggy.

Denis
The administrator has disabled public write access.

why cannot upload img to question? 9 months 3 weeks ago #105281

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5501
  • Thank you received: 312
  • Karma: 253
To me this looks like a server side problem. What happens if you upload other files like PDF?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

why cannot upload img to question? 9 months 3 weeks ago #105324

  • iscar
  • iscar's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 216
  • Thank you received: 1
  • Karma: 0
for find out the reason,i updated to 2.05 version.
then i upload img, jump out"CSRF upload error".
i am not sure it hint the problem reason.
The administrator has disabled public write access.

why cannot upload img to question? 9 months 3 weeks ago #105325

  • iscar
  • iscar's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 216
  • Thank you received: 1
  • Karma: 0
in the same server, i have an phpbb forum, i can upload img to forum.
The administrator has disabled public write access.

why cannot upload img to question? 9 months 3 weeks ago #105368

  • iscar
  • iscar's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 216
  • Thank you received: 1
  • Karma: 0
i transfer all files to localhost, the img is ok to upload.
it seemed to be environment problem. but i have not figure the problem out.
i guess it will be folder route problem, but as i am not familiar with ckeditor, i cannot lock the script line which execute the write action.
Last Edit: 9 months 3 weeks ago by iscar.
The administrator has disabled public write access.

why cannot upload img to question? 9 months 3 weeks ago #105380

  • iscar
  • iscar's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 216
  • Thank you received: 1
  • Karma: 0
i use firebug, it shows /survey/scripts/jquery/jquery.js line 16 is not a function.
i checked the mysql database, the img url is record in correct folder. but ckeditor cannot write img into this folder.
i guess the problem is caused by ckeditor urlbase.
The administrator has disabled public write access.

why cannot upload img to question? 9 months 3 weeks ago #105384

  • iscar
  • iscar's Avatar
  • OFFLINE
  • Gold Lime
  • Posts: 216
  • Thank you received: 1
  • Karma: 0
i guess something wrong caused by the survey import.
i have export .lss from version 2.05, and import to the existing version 2.0 system.
is that action will cause the problem?
The administrator has disabled public write access.

why cannot upload img to question? 9 months 3 weeks ago #105385

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5501
  • Thank you received: 312
  • Karma: 253
iscar, if files are not stored on disk when using file upload, that is mostly a server issue. Check if /upload/* is writable for the webserver and contact your host for more information if the problem persist.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.129 seconds
Donation Image