Welcome, Guest
Username: Password: Remember me

TOPIC: Make question idx NOT red when section has array (numbers) check box question?

Make question idx NOT red when section has array (numbers) check box question? 1 year 2 weeks ago #100633

  • w0928
  • w0928's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 33
  • Thank you received: 3
  • Karma: 1
By default, the labels for each section listed in the question index are red when a section contains questions that have not be answered.

I've noticed though, that for my sections which have an array (numbers) question with checkbox style set to yes that those section are always red... even when at least 1 column has been checked for every row for the question.

So my question is, what conditions must be satisfied for the question index to count such questions as having been completed by the user and how would I go about changing that?
The administrator has disabled public write access.

Make question idx NOT red when section has array (numbers) check box question? 1 year 2 weeks ago #100706

  • w0928
  • w0928's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 33
  • Thank you received: 3
  • Karma: 1
I found this in the bugs section. It is marked as fixed but I am having the same issue so maybe this was not quite fixed?

bugs.limesurvey.org/view.php?id=5323

Edit: I'm using version 2.00+ (build 130802) Aug 2, 2013.
Last Edit: 1 year 2 weeks ago by w0928.
The administrator has disabled public write access.

Make question idx NOT red when section has array (numbers) check box question? 1 year 6 days ago #101014

  • w0928
  • w0928's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 33
  • Thank you received: 3
  • Karma: 1
I have a little more info to provide on this issue. I noticed that in cases where the question index was red and the user submits the survey the checkboxes that are left unchecked are being saved to the database as null and in the case where it is not red the checkboxes that are left unchecked are being saved as 0.

I would really appreciate it if a developer would comment on this issue. Is this working as intended? What is causing the discrepancy for the question index coloring and the values that get saved? They appear to correlate with one another.

Thank you.
Last Edit: 1 year 6 days ago by w0928.
The administrator has disabled public write access.

Make question idx NOT red when section has array (numbers) check box question? 1 year 6 days ago #101018

  • w0928
  • w0928's Avatar
  • OFFLINE
  • Junior Lime
  • Posts: 33
  • Thank you received: 3
  • Karma: 1
More info: the missing class is being added to the array numbers question just like it was reported in this bug report:

bugs.limesurvey.org/print_bug_page.php?bug_id=5323

Maybe the bug crept its way back in?
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.093 seconds
Donation Image