Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Problems during installation - version 2

Problems during installation - version 2 1 Jahr 5 Monate her #93404

(I'm sorry for my rusty English)

I need help: I am not able to install!

During installation, after the mask in annex 1 (80%installation, after creation of database tables), the mask in the second attachment appears.

I thought (I hoped) the installation had gone, so I tried as described in "9. Connect to the administration script for the first time":
- I typed http://my-domain-name/limesurvey/admin/admin.php
- a page similar to the second attachment appeared and the address changed to "http://my-domain-name/LimeSurvey/index.php/admin."

Any other attempt was useless and I didn't found documentation about my problem.

As you can understand, I don't know php, so I don't know what to do to solve the problem.

Can anyone help me?
Thanks.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Problems during installation - version 2 1 Jahr 5 Monate her #93414

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6252
  • Dank erhalten: 799
  • Karma: 239
Hello,

Maybe this strange issue can be put in bug report system with complete information from server.
Seem more a Yii problem but not sure.

1st solution to try: review your directory name in ftp: if it's LimeSurvey rename it to limesurvey.
2dn solution, forece rooturl in config.php:
'config'=>array(
		'debug'=>0,
		'debugsql'=>0,
                'publicurl'=>'http://example.org/limesurvey/'
	)
Letzte Änderung: 1 Jahr 5 Monate her von DenisChenu.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Problems during installation - version 2 1 Jahr 5 Monate her #93433

Thank you for your replay.

I tried 1st solution (I renamed LimeSurvey into limesurvey).
Something changed:
- I typed .../limesurvey/admin/admin.php
- The result was a blank page with "No input file specified." and url modified in ".../limesurvey/index.php/admin"

Have I to repeat installation naming directory "limesurvey", not "LimeSurvey"?

I am going to apply 2dn solution.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Problems during installation - version 2 1 Jahr 5 Monate her #93434

I tried 2st solution.
I added 'publicurl'=>'example.org/limesurvey/'; it was not necessary modify 'debug'=>0 and 'debugsql'=>0

Something changed again:
- I typed .../limesurvey/admin/admin.php
- The result was a completely blank page; the url was not modified.

I attached some files to help you to help me :-)
config.php in ...limesurvey/application/config modified with line added
admin.php and index.php in .../limesurvey/admin

I hope that you understand the problem.
Letzte Änderung: 1 Jahr 5 Monate her von frank4wheels.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Problems during installation - version 2 1 Jahr 5 Monate her #93435

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6252
  • Dank erhalten: 799
  • Karma: 239
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Problems during installation - version 2 1 Jahr 5 Monate her #93447

I modified as shown in www.limesurvey.org/en/forum/installation...file-specified#92339:
from
'urlFormat' => 'path',
to
'urlFormat' => 'get',

but nothing changed
- I typed .../limesurvey/admin/admin.php
- The result was a completely blank page; the url was not modified.

Do you need other information?
Have I to repeat installation naming directory "limesurvey", not "LimeSurvey"?

Thanks.

I don't understand why attachments are not loaded. :angry:
Letzte Änderung: 1 Jahr 5 Monate her von frank4wheels.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Problems during installation - version 2 1 Jahr 5 Monate her #93448

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6252
  • Dank erhalten: 799
  • Karma: 239
Think you made error on config.php, no ; after 'publicurl'=>'example.org/limesurvey/'

Review config.php and put exactly that after that sentence:
// Use the following config variable to set modified optional settings copied from config-defaults.php
'config'=>array(
	// debug: Set this to 1 if you are looking for errors. If you still get no errors after enabling this
	// then please check your error-logs - either in your hosting provider admin panel or in some /logs directory
	// on your webspace.
	// LimeSurvey developers: Set this to 2 to additionally display STRICT PHP error messages and get full access to standard templates
	// traceVar($variable, $depth = 10)
		'debug'=>2,
		'debugsql'=>0,
		'urlFormat' => 'get'
	)
);
/* End of file config.php */
/* Location: ./application/config/config.php */
Letzte Änderung: 1 Jahr 5 Monate her von DenisChenu.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: frank4wheels

Problems during installation - version 2 1 Jahr 5 Monate her #93455

Now it works!

I had to add user "admin" in db, because it wasn't; but now works.

Thank you very much.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Problems during installation - version 2 1 Jahr 5 Monate her #93459

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6252
  • Dank erhalten: 799
  • Karma: 239
frank4wheels schrieb:
Now it works!

I had to add user "admin" in db, because it wasn't; but now works.

Thank you very much.
OK.

Maybe there are some other information not set. Think it's best to redo the installation with good name for directory.

Denis
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: frank4wheels
Moderatoren: ITEd
Ladezeit der Seite: 0.312 Sekunden
Donation Image