Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: PostgreSQL 9.1 - Problèmes sur langue par défaut

PostgreSQL 9.1 - Problèmes sur langue par défaut 1 Jahr 5 Monate her #87549

  • riqcles
  • riqcless Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 103
  • Dank erhalten: 6
  • Karma: 0
Sur mon serveur local (Wamp/postgresql 9.1), je réalise une installation de la version 2.0 build 121025.
J'indique tous les paramètres nécessaires pour la connexion à la BDD et l'administration de l'application.
Je précise que la langue par défaut est le français. :lol:

Je me connecte et déconnecte plusieurs fois sans aucun problème.
J'ai ensuite choisit, à l'écran de connexion, la langue française.
Pas de problème pour me connecter la première fois.
Puis impossible de se connecter. :blink:
J'ai beau changer la langue, ou remettre defaut -> impossible de se connecter.

Je suis obligé de "casser" mon installation : :S
1. suppression du schema public (le seul reconnu par limesurvey) dans pgadmin
2. recreation du schema public
3. suppression du fichier config.php
4. relance de la procédure d'installation.

J'ai essayé plusieurs fois avec la langue anglaise ou française, en vidant les caches du navigateurs -> toujours KO

Je ne rencontre pas le problème sous Mysql. :woohoo:

C'est en réalisant des tests avec Selenium (pour la bascule des deux langues) que j'ai vu ce problème.

Demain, je tente de faire les même manips sur mon serveur de Dev sous Centos.
J'ajoute une vidéo sous wink pour montrer le problème.

Si des utilisateurs de postgresql peuvent me faire un retour

Merci.

Je rajoute le lien pour la vidéo : dl.free.fr/h5a21rFWJ
@moderateur : je peux pas ajouter de video au format swf dans un zip (utilisation de Wink), normal ?
LimeSurvey 2.00 build 130611 / 1.92+ build 120909 / 1.85+
VirtualBox/WinXP SP3/EasyPHP 12/ PHP 5.3.13/ PostGresql 9.1 /PostGresql 8.4.11
Letzte Änderung: 1 Jahr 5 Monate her von riqcles.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: PostgreSQL 9.1 - Problèmes sur langue par défaut 1 Jahr 5 Monate her #87568

  • Nickko
  • Nickkos Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 1927
  • Dank erhalten: 216
  • Karma: 43
Je ne gère pas directement ce qu'il est possible d'uploader mais normalement les zip passent, peut-être est-ce la taille qui est trop grosse.
Nickko
Ergonome / Usability expert
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: PostgreSQL 9.1 - Problèmes sur langue par défaut 1 Jahr 5 Monate her #87583

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 5838
  • Dank erhalten: 714
  • Karma: 222
Salut,

Je testerais et j'essaierais de trouver, mais franchement, je ne vois pas trop ou cela peut intervenir.

Tu peux tenter un debug à 2 et vérifier tes logs ?

Denis
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: PostgreSQL 9.1 - Problèmes sur langue par défaut 1 Jahr 5 Monate her #87600

  • riqcles
  • riqcless Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 103
  • Dank erhalten: 6
  • Karma: 0
@Nickko : la taille était d'environ 1 300 ko. Je pense pas que c'est trop. Bon si le lien fonctionne et que cela ne gène pas, ca me va.

Voila les résultats sur mon serveur de Dev sous CentOS : même constat !

J'ai poussé les tests encore plus loin :

1.installation standard de limesurvey (sans script, par l'installateur).
2. A la fin du script l'admin principal est créé ( admin1)
3. création d'un nouveau utilisateur superadmin (admin2)
4. connexion et deconnexion avec admin1 -> Ok
5. connexion et deconnexion avec admin5 -> Ok

6. connexion, choix de langue "français" et deconnexion avec admin1 -> Ok
7. connexion, choix de langue "defaut" avec admin1 -> Ko
8. connexion, choix de langue "français" avec admin1 -> Ko
9. connexion, avec n'importe quel choix de langue avec admin1 -> Ko

10. connexion, choix de langue "defaut" avec admin5 -> Ok
11. edition du mot de passe de admin1 -> je remets le même.
12. déconnexion de admin5 -> OK
13. connexion avec admin1, choix de langue "defaut" -> Ok

14. modification de la langue par défaut dans les paramètres du questionnaire (ex: English)
15. deconnexion de admin1 -> OK
16. connexion avec admin1, choix de langue "defaut" -> connexion ok mais langue en français

17. deconnexion de admin1 -> OK
18. connexion avec admin5, choix de langue "English" -> connexion ok mais langue en français
19. deconnexion de admin5 -> ok
20. connexion, choix de langue "defaut" avec admin5 -> OK (langue toujours français).

21. deconnexion de admin5 -> ok
22. connexion, choix de langue "français" et deconnexion avec admin1 -> Ok
23. connexion, choix de langue "defaut" avec admin1 -> Ko


Moralité : je dois me connecter avec admin5 pour réinitialiser le mot de passe d'admin1.

Autre chose :
dans pgadmin, pour la table lime_user le paramètre de langue change pour l'admin principal (admin dans la capture d'écran) et jamais pour les autres (admin2 et admin3), il est toujours a auto (quelquesoit la langue choisi).
Anhang:
LimeSurvey 2.00 build 130611 / 1.92+ build 120909 / 1.85+
VirtualBox/WinXP SP3/EasyPHP 12/ PHP 5.3.13/ PostGresql 9.1 /PostGresql 8.4.11
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: Nickko
Ladezeit der Seite: 0.151 Sekunden
Donation Image