Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Language issue

Language issue 4 Monate 2 Wochen her #107675

  • SharkTanq
  • SharkTanqs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 3
  • Karma: 0
Hello

I installed LimeSurvey in English, but I wanted my first survey to be in another language. Unfortunately, even though I picked the second language for my survey, all the instructions still appear in English. For example: "Check all that apply", "Yes/No" option etc.

Is there a bug in the system? Or is it too late to edit language AFTER you started adding questions to the survey? I spent about 2 hours setting it up, so I hope it's possible to solve this!

Also, I noticed another problem. When a survey taker does not fill out a mandatory field and clicks "next", he/she gets an error message and all the answers he/she inserted are wiped out! Of course, I want the survey takers to fill out all mandatory forms, but I would prefer the answers to be saved, so he or she does not have to do all the group questions again.

Please let me know how I can fix this.

And also, thank you for this great piece of program!!
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Language issue 4 Monate 2 Wochen her #107686

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6277
  • Dank erhalten: 802
  • Karma: 241
LimeSurvey version ?

And did you have suhosin activated ?

Denis
* No bug like this in LS.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Language issue 4 Monate 2 Wochen her #107695

  • SharkTanq
  • SharkTanqs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 3
  • Karma: 0
The newest version.

How about saving responses when the page reloads because one mandatory question is not answered?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Language issue 4 Monate 1 Woche her #107703

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6277
  • Dank erhalten: 802
  • Karma: 241
Did you have suhosin activated ?

Because defalt behaviour is to show survey again, with error but without loose answers
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Language issue 4 Monate 1 Woche her #107712

  • SharkTanq
  • SharkTanqs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 3
  • Karma: 0
I dont know to be honest, I've never heard of it. How can I check if its activated or not?

All I want is for the answers to be saved in case there is 1 of 9 questions that are not answered. It would be bad for participants to have to re-do ALL questions just because one answer was missed.

When one answers is missed, all Qs are marked red and with the error "Please pick one answer". I only want this to happen with the question the user actually did not answer.
Letzte Änderung: 4 Monate 1 Woche her von SharkTanq.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Language issue 4 Monate 1 Woche her #107715

  • holch
  • holchs Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 2643
  • Dank erhalten: 313
  • Karma: 115
What you want is the standard behaviour, so there seems to be something wrong with your installation. So if the respondent clicks on submit, all questions are marked as not answered, even the ones that have been answered? That seems to be strange. Can you add an example questionnaire, where this happens? Or try your questionnaire in the test installation here on Limesurvey.org. If the problem does not appear there, we know at least that it is not the questionnaire itself, but your installation/server and we can go from there.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.135 Sekunden
Donation Image