Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: bug report: Quick Translation entry are not saved

bug report: Quick Translation entry are not saved 9 Monate 2 Tage her #105546

  • ROSt52
  • ROSt52s Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 57
  • Dank erhalten: 1
  • Karma: 0
I tried several times to report a bug at bugs.limesurvey.org/view_all_bug_page.php but I can neither login nor create a new account only for bug reports, thus the bug report here.

I added a second language to an existing, still inactive survey.
Base language: English
Additional language: Japanese

Used "Quick translation"
Question groups, question and subquestion can be translated and saved without problem.

Problem 1

Answer options can be translated but after saving the translated Japanese text does not show up, only the English text. "Does not show up" means only the English text is to be seen in the "Test this survey, Japanese" window and in the export of a printable version.
Saving procedure was verified several times:clicking the "save" button at the end of the list.


Workaround of doing translation in Edit Question Windows does not work as well.

Problem 2
When I edit the Japanese subquestion or answer options in the Japanese tab, the content in the English tab is over written by the Japanese text.

Should someone have a solution to this problem I appreciate any help. Otherwise, just take this as bug report.

Attached images show the problem with the not save answer option. In image 1 is the a strange behavior to be seen. The first answer option could be saved but none of the others. Also here additional verification by repetition were made.


Version used: Version 2.00+ Build 130406 on XP/SP3.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

bug report: Quick Translation entry are not saved 9 Monate 1 Tag her #105632

  • ROSt52
  • ROSt52s Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 57
  • Dank erhalten: 1
  • Karma: 0
The bug is the same in
Version 2.00+ Build 131206

I am willing to contribute to testing of English and Japanese surveys.
Letzte Änderung: 9 Monate 1 Tag her von ROSt52.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

bug report: Quick Translation entry are not saved 9 Monate 1 Tag her #105635

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6551
  • Dank erhalten: 869
  • Karma: 257
Hi,

Best is to put a bug report. For the 1: Quick translation must be rewritten to be more quick and easy.
For the 2 : it's with quick translation too ?

Denis
Der Administrator hat öffentliche Schreibrechte deaktiviert.

bug report: Quick Translation entry are not saved 9 Monate 5 Stunden her #105701

  • ROSt52
  • ROSt52s Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 57
  • Dank erhalten: 1
  • Karma: 0
Hi Denis, thanks for encouraging me to file a bug report. I would like to do it but somehow I am just to stupid to do it. See also the very beginning of this forum entry. Best intentions from my side but NEVER successful. I hope for your understanding. Maybye you can copy the information into a bug report.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

bug report: Quick Translation entry are not saved 9 Monate 5 Stunden her #105702

  • ROSt52
  • ROSt52s Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 57
  • Dank erhalten: 1
  • Karma: 0
Encouraged by emimarz reply in
www.limesurvey.org/en/forum/can-i-do-thi...ecause-it-is-not-new
and the fact that I upgrade the SW I made a new test.

With the Version 2.00+ Build 131206 I created a new survey via import of an TAB/TXT file. The TAB/TXT file contains the English and Japanese version of the survey. Previously the survey was based on a copy of an active survey.

Reference to PROBLEM 1
Next I added a third language, German and see exactly the same behavior as with Japanese. Especially I see in the German quick translation again the strange behavior which is shown in image 1 The first Answer Option can be translated and saved. Starting with the second Answer Option saving is not possible. Thus I conclude that the problem is not caused by the double byte characters of Japanese.

Reference to PROBLEM 2
This problem with disappeared.with the latest SW version indicated above but only for Answer Options.
Editing a question and entering a Japanese text in the Japanese tab of Answer Option works without overwriting of the English or German text. The same is valid for entering German text in the German tab. Removing the German text to have only 2 languages (English and Japanese) everything functions well.
However the problem remains for subquestions.

If someone wants to look into exported files please contact me and I create the exports for uploading here.
Letzte Änderung: 9 Monate 4 Stunden her von ROSt52.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

bug report: Quick Translation entry are not saved 8 Monate 4 Wochen her #105745

  • ROSt52
  • ROSt52s Avatar
  • OFFLINE
  • Senior Lime
  • Beiträge: 57
  • Dank erhalten: 1
  • Karma: 0
As I saw that Version 2.05+ Build 140226 is available I upgraded to this version and tested again the survey used for #105546

Quick translation:
Works not for answer options
Works for sub-questions

Editing questions
Works for questions. I can add text in English and Japanese and they don't overwrite each other
Does not work for answer options and sub-question. Japanese overwrites English also English was saved before switching to the Japanese tab.

I repeated the same test for German after adding German as a third language and got the same results.

My conclusion is that unfortunately LimeSurvey cannot be used for bilingual surveys in English and Japanese, or English and German. For me this means. I have to create two separate surveys, each with its own language.

Still I am willing to contribute to the bug fixing; please advice what I can do to help to improve LimeSurvey.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.135 Sekunden
Donation Image