Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Questions randomly disappear

Questions randomly disappear 10 Monate 2 Wochen her #101551

  • Spronk
  • Spronks Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 4
  • Karma: 0
Hi everyone,

for my survey the participants need to fill in properties that are true for given objects. Those objects are pictures. So I've made a question group (question by question) with 30 questions. Every question is basicly a picture with a "long range text" underneath it. However. While running a preview of the whole survey, some questions disappear randomly. For example, sometimes picture #11 disappears but sometimes it does not. Also the order of disappearence is random. Sometimes the third question gives a blank screen, sometimes it does not. Usually around the half of all questions don't appear. According to the Question-Logic file, everything works fine... but it does not!

Please help me out.

Thank you very much!

__
I use LimeSurvey 2.00+
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 2 Wochen her #101573

  • tpartner
  • tpartners Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 4210
  • Dank erhalten: 792
  • Karma: 360
Are there any conditions or relevance applied to the questions?

Does the whole question disappear or just the images.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: Spronk

Questions randomly disappear 10 Monate 2 Wochen her #101588

  • Spronk
  • Spronks Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 4
  • Karma: 0
Well, the whole question disappear. The thing I could think of, is that the questions are randomised. But I didn't find an error on that. But redoing everything. And so far, that version works fine. Thank you for your reply though :)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 2 Wochen her #101605

  • mofog
  • mofogs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 18
  • Dank erhalten: 3
  • Karma: 2
Hi there. I think I'm experiencing the same strange behavior. Did you resolve this by just re-doing everything? If so, what did you do differently the second time? Thanks.

I discovered that this only happens if the question groups as well as the individual questions are randomized via one randomization group. If I remove that randomization group – and make the survey thus static – no question disappears.
Anhang:
Letzte Änderung: 10 Monate 2 Wochen her von mofog.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 2 Wochen her #101617

  • Spronk
  • Spronks Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 4
  • Karma: 0
Hi mofog,

I had the exact same screen. I made the same discovery while re-doing everything. This problem is solved now. Topic closed?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 2 Wochen her #101618

  • mofog
  • mofogs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 18
  • Dank erhalten: 3
  • Karma: 2
Hi Spronk!
Spronk schrieb:
I made the same discovery while re-doing everything.

Does that mean that you're still facing this problem or did it go away just after deleting and creating a new survey? I don't really feel that this is solved, is it?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 2 Wochen her #101619

  • Spronk
  • Spronks Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 4
  • Karma: 0
For my survey, it is solved now though.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 1 Woche her #101726

  • mofog
  • mofogs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 18
  • Dank erhalten: 3
  • Karma: 2
I'm sorry, I re-created the same survey over and over again and I'm still facing this problem. Could anyone help me out, please? Thanks.

Edit:
I narrowed it down to the following line of code in SurveyRuntimeHelper.php:
foreach ($qanda as $qa) // one entry per QID
{
  if ($gid != $qa[6]) {
    continue; // <-- this happens
  }

Apparently, the question's group id does not match the id of the currently presented group. Strange.
Since there are quite a few magic numbers and ambiguous variables in the code, I could not discover the root of the problem yet.
Letzte Änderung: 10 Monate 1 Woche her von mofog.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 1 Woche her #101740

  • tpartner
  • tpartners Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 4210
  • Dank erhalten: 792
  • Karma: 360
Please file a bug report and...

1. Give as much information as possible.
2. Provide step-by-step instructions how to reproduce the problem.
3. Provide screenshots and a sample survey.
4. Post the link to the bug here so we can follow the progress.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Questions randomly disappear 10 Monate 1 Woche her #101745

  • mofog
  • mofogs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 18
  • Dank erhalten: 3
  • Karma: 2
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.188 Sekunden
Donation Image