Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Sub-questions not getting scored?

Sub-questions not getting scored? 1 Jahr 2 Wochen her #100372

  • vector
  • vectors Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 12
  • Karma: 0
I searched around and didn't see any submitted posts about this. Seems like questions that only show up during certain conditions don't get counted in the results even if their default answer is set to an option. Example:

Each of the questions on my survey have a "yes" or "no" answer and a comment field. Some questions only show up IF a previous question was answered "yes". Those sub-questions that depend on the "yes" answer have their default answers set to "no". If I click "yes" on the parent question, the sub-questions get scored no problem. If I leave the parent question at "no" -- which is it's default -- the sub questions do NOT get scored. Going to try to make the parents so they do not have default answers, and see what happens in that scenario. It's almost like the sub-answers need to show up on screen for Limesurvey to count them. Hopefully this was the right forum.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Sub-questions not getting scored? 1 Jahr 2 Wochen her #100384

  • tpartner
  • tpartners Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 4270
  • Dank erhalten: 803
  • Karma: 368
It it normal behaviour that questions hidden with conditions or relevance are not included in the results.

To change that, have a look at $deletenonvalues - manual.limesurvey.org/Optional_settings#Survey_Behavior
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Letzte Änderung: 1 Jahr 2 Wochen her von tpartner.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.133 Sekunden
Donation Image