Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: survey stopped moving next page.

survey stopped moving next page. 1 Jahr 2 Monate her #97988

  • trivender
  • trivenders Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 142
  • Dank erhalten: 6
  • Karma: 6
My survey question are reached to 120 and I am having few issues with my survey . Please let me know the most probable reasons for this.I have duplicated my survey few times while creating survey.

Main survey is not moving forward from the first question. When I click next then it goes to the previous screen ie "Your survey has XXXX question.". I left this survey and started working on a backup which I took before deleting few question from the survey.

I deleted all those questions from my duplicate survey and started working on it .. it worked fine for some time but now it is also having an issues ...Survey starts fine but at some question it gives a pop up with message "Please use the Lime Survey navigation buttons or index. It appears you attempted to use the browser back button to re-submit a page." and then dont move to next question.

This survey is very important to us .. Please let us know when could be the reason for this.
Trivender Singh
Survey Designer and Programmer
"I always suggest to have a group by group display layout and create a seprate group for each question. This will be extra work but you will get flexiblity to create your question by using more than more lime survey question types."
Der Administrator hat öffentliche Schreibrechte deaktiviert.

survey stopped moving next page. 1 Jahr 2 Monate her #98032

  • titadvarf
  • titadvarfs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
I have a similar problem, although it doesn't always happen. I have a 4 page survey and sometimes can't advance past the first page. It seems stuck on page one.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

survey stopped moving next page. 1 Jahr 2 Monate her #98038

  • utsi
  • utsis Avatar
  • OFFLINE
  • Junior Lime
  • Beiträge: 25
  • Dank erhalten: 1
  • Karma: -2
I'm facing a similar problem too. But the surprising thing is that if I export that survey from the server and import it into localhost and then run it, it works. So localhost works fine, while on server it gets redirected back to the previous page.

However, on the server if the survey is not active, it runs without this issue. As soon as I make it active, the redirection problem steps in.

One more thing I noticed is that if I remove grid questions from the survey, all starts to work as expected even if the survey is active. So maybe I'm thinking the issue might be the grid question, but unable to detect it.

In a nutshell, this is what I found out so far after various trials:
  • On localhost, the survey runs fine (both active and inactive mode)
  • On server, the survey runs fine only in inactive mode
  • On server if I remove the grid questions and then activate the survey and run, all issues go away

Any idea on what could the reason behind this?
Letzte Änderung: 1 Jahr 2 Monate her von utsi.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: trivender

survey stopped moving next page. 1 Jahr 2 Monate her #98039

  • titadvarf
  • titadvarfs Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
I should have added that my 4 page survey is also only a problem on the server but the other issue is that it is presented in an iFrame. It works OK on my Mac but not on my iPad or on a friend's computer - not sure what OS or browser he's using. I'm wondering if this is an iFrame problem that varies depending on the browser used?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

survey stopped moving next page. 1 Jahr 1 Monat her #99439

  • FHemmes
  • FHemmess Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 10
  • Dank erhalten: 1
  • Karma: 0
Hi utsi,

Did you eventually find a solution to this problem? I am having similar issues. Survey runs fine when tested on local machines, but some participants are reporting back that they cannot proceed past the first page.

Which question type do you mean with 'grid question'? I am using the drag-and-drop ranking type question on the first page, and am inclined to think this causes the issue.

Cheers,
FH
Der Administrator hat öffentliche Schreibrechte deaktiviert.

survey stopped moving next page. 1 Jahr 1 Woche her #99996

  • utsi
  • utsis Avatar
  • OFFLINE
  • Junior Lime
  • Beiträge: 25
  • Dank erhalten: 1
  • Karma: -2
Hi FHemmes. I finally got the solution. The problem was insufficient memory on the server. Since the server was too long, the server was running out of memory.

So I forced to increase the memory limit by putting
ini_set('memory_limit', '-1');
inside the php file. I wouldn't suggest this though as it isn't the best solution. I'm using it for temporary basis though.
Letzte Änderung: 1 Jahr 1 Woche her von utsi.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

survey stopped moving next page. 1 Jahr 1 Woche her #100002

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6358
  • Dank erhalten: 824
  • Karma: 245
There are a settings in config for this purpose.
$config['memory_limit']        =  '32';

You can put
'memory_limit'=>'256'
in the config array in config.php
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.303 Sekunden
Donation Image