Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: token attribute mixed-up

token attribute mixed-up 1 Jahr 2 Monate her #95977

  • ricardo
  • ricardos Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 110
  • Dank erhalten: 1
  • Karma: 0
I'm using Version 2.00+ Build 130428

I set up a token list and added a new field attribute_1. The new field was "January 2013" or "August 2012"

I set up an invitation like this:

invitationemail.PNG


However, some people have emailed to me saying that date is not correct. For example, the date for this person is August 2013,

tokenlist_2013-05-14.PNG


but his email shows January 2013.

invitationtruncated.PNG




Other people simply did not get the date:


invitationnodate.PNG


Has anybody else had the same problem?
Letzte Änderung: 1 Jahr 2 Monate her von ricardo. Begründung: wrong pic
Der Administrator hat öffentliche Schreibrechte deaktiviert.

token attribute mixed-up 10 Monate 4 Wochen her #99380

  • papacico
  • papacicos Avatar
  • OFFLINE
  • Junior Lime
  • Beiträge: 20
  • Karma: 0
hello Ricardo,

yes i have the same problem the {token:attribute_1} is not returning the value from the token table,

did you already solved this problem? Could you please share the solution?

Thank you bye
Der Administrator hat öffentliche Schreibrechte deaktiviert.

token attribute mixed-up 10 Monate 3 Wochen her #99400

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6207
  • Dank erhalten: 788
  • Karma: 238
If this happen with last version too, please report the bug.

But i think i see a fix for that some week ago.

Denis
Der Administrator hat öffentliche Schreibrechte deaktiviert.

token attribute mixed-up 10 Monate 3 Wochen her #99441

  • FHemmes
  • FHemmess Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 10
  • Dank erhalten: 1
  • Karma: 0
Hello ricardo, papacico,

I had the same problem some time ago. The email invitations would sometimes load the right tokens, sometimes the wrong ones, and sometimes none at all.

What made the difference for me was using the field replacement tags without the word 'TOKEN' in them. So use {ATTRIBUTE_1} instead of {TOKEN:ATTRIBUTE_1}. Include 'TOKEN' only in the field replacement tags you build into the survey itself.
This solved the problem for me. You can find my thread on this problem here: www.limesurvey.org/en/forum/design-issue...butes-in-invitations

There is also a page in the manual related to replacement field tags that has information on this here: manual.limesurvey.org/Tokens#Emailing

I hope this solves your problem.

Best,
FH
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: papacico

token attribute mixed-up 10 Monate 3 Wochen her #99457

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6207
  • Dank erhalten: 788
  • Karma: 238
DenisChenu schrieb:
If this happen with last version too, please report the bug.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: papacico

token attribute mixed-up 10 Monate 3 Wochen her #99502

  • papacico
  • papacicos Avatar
  • OFFLINE
  • Junior Lime
  • Beiträge: 20
  • Karma: 0
thank you Fhemmes and Denis the issue is solved using {ATTRIBUTE_1}

kind regards
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.160 Sekunden
Donation Image