Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Admin exits out to login screen only on one survey

Admin exits out to login screen only on one survey 1 Jahr 4 Monate her #95218

Hello,

We're running 2.00+ (130406) on mysql/apache/linux. We are running into a weird problem. We have many surveys in our system and they are all working perfectly. However, one of our most recently created surveys has a large number of questions (129) in 5 groups and for some reason admin exits immediately when trying to change ANY setting in the group. The weird thing is the setting you change appears to save, but then it sends you out to the login page.

The problem only happens on this one survey.

Here's what I've tried:
  1. Exporting the survey to lss and reimporting, imported survey exhibits the problem as well
  2. Checking for UTF8 characters
  3. Increasing RAM, both PHP and in the limesurvey config
  4. Checking server logs, no log entries
  5. Turning on debug mode and sql debug mode, no log entries at all
  6. Removing groups and questions from the survey
  7. Running MyISAM check/analyze/repair on the limesurvey database
  8. Running database repair in limesurvey
  9. Running condition checker in debug mode, survey comes back as OK
  10. Attempting operation with other admin accounts
  11. Checked PHP sessions

It should be noted, the survey has a conditional on almost every question. It is only this survey, which makes it less likely to be a server config issue. The FAQ has this question, and all of it deals with server settings. However, I am only getting the problem on this one survey.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Admin exits out to login screen only on one survey 1 Jahr 4 Monate her #95220

Update: I was able to get it to stop exiting to the admin login by deleting a question from the last section. When I add any question back, the problem starts again. It looks pretty clearly like the question count is too high. I would think this would be a good thing for the software to check for and throw an error on.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Admin exits out to login screen only on one survey 1 Jahr 4 Monate her #95225

  • mdekker
  • mdekkers Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 341
  • Dank erhalten: 68
  • Karma: 38
Probably some kind of rare condition (duplicate question code/id missing value etc.) confuses the script.

If you edit your /application/config.php at the end and set debug from 0 to 2 and if that produces an error, could you please post that in a bugreport? That way we can possibly fix the problem you run into. 129 questions / 5 groups should not really be a problem I think.
---
Menno Dekker
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.141 Sekunden
Donation Image