Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Limesurvey;Social Network Survey, help with a difficult question

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94622

  • holch
  • holchs Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 2569
  • Dank erhalten: 292
  • Karma: 106
To be honest your way isn't bad at all.

I know! That is why I suggested it. :laugh:

I think even from a research point of view I would prefer it, because it is a lot easier for respondents to mark the brands they know than to mark all brands in some way, especially with a list of 400 brands (who the hell will answer something like this?). I would split this question in various questions anyway.

You must be doing something wrong, because here it works perfectly.

here a screenshot:
Screenshot_1_2013-04-05.png


And here a sample question group with the two questions:

Dateianhang:

Dateiname: limesurvey_group_21.lsg
Dateigröße: 7 KB


I think this should make things clearerl
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94669

  • Teddian
  • Teddians Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
So I tried your question group, that is I imported it, changed ur options with my predefined label set (my options) and it didnt work. Is it possible that there is some kind of limit of answers (mine are 325 atm, maybe I should break it down to smaller samples?) in limesurvey?Or is it possible that my dual language (greek and english) has something to do with it?
This is really annoying cause it should be straightforward :(

Edit: Something I forgot, which could be irrelevant. Every time I 'quick add' or add from a predefined label set I get an error called "failed to delete answer" and then when I use back in the browser it sais "subquestions successfully saved". Could be relevant..

Thank you for all the help.
Letzte Änderung: 1 Jahr 3 Monate her von Teddian.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94671

  • Teddian
  • Teddians Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
Okay this works!It just needs less answer options for some reason. Maybe there is a max_limit of answer options somewhere in the code, idk. In any case thanks for all your help and hopefully I will not need to bother you no more :)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94673

  • Teddian
  • Teddians Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
New problem :(

As I said above, it worked with around 80 companies (answer options). But when I made a new couple of questions (one multiple, one array-text) for the next 80 companies, nothing happens. Anything I do I cannot make it work. Moved it to different question group, changed names, question id's..I am sorry for repeating myself but this is frustrating..
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94674

  • Teddian
  • Teddians Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
I don't know what else to do. Now even the questions that do work, fail to work if I edit the answer options (either add manually, replace from predefined sets etc.). I am starting to think this is a database issue and not some option in my questions :( And I think it's connected to the "cannot delete answer" message that keeps popping up everytime I edit something.
Anyone knows what to do?Should I start a new survey alltogether?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94675

  • holch
  • holchs Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 2569
  • Dank erhalten: 292
  • Karma: 106
Maybe you are running in some kind of limit of your database. Where are you hosting your limesurvey?

Can you export your survey and post it here?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: Teddian

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94695

  • Teddian
  • Teddians Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
Thanks for your help once more!I am not hosting it yet, it's stored locally. I am using XAMPP to do that.
Here is the survey structure file. Bear in mind that you it has greek and english as languages. The questions bothering me are the last two. Also, you will need to put something in question 9 in order to progress.
Anhang:
Letzte Änderung: 1 Jahr 3 Monate her von Teddian. Begründung: Couldn't upload the file structure
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94713

  • holch
  • holchs Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 2569
  • Dank erhalten: 292
  • Karma: 106
As the base language is Greek it is quite difficult to find the correct questions, as even the numbers do not fit with the English version. I will see if I can make my way trough.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94715

  • holch
  • holchs Avatar
  • OFFLINE
  • LimeSurvey Team
  • Beiträge: 2569
  • Dank erhalten: 292
  • Karma: 106
I found something that might be the cause of your problem: The answer codes in question G4Q4 and E45 must be exactly the same.

However, there was a 51 somewhere in the middle and missing later, so I haven't looked much further.

You can use Excel and the quick-add feature to add long lists quite quickly and save. In the first cell you put the answer code and in the second cell the answer itself. Then copy all answers and answer codes and insert them into the quick add field and it usually recognizes automatically the answer code and the answer and inserts everything correctly. Additionally you could also just copy the first question to use it as a base for the second question. You just change the question type and make the necessary modifications.

Let's hope that this is your problem, because this is easy to solve.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: Teddian

Limesurvey;Social Network Survey, help with a difficult question 1 Jahr 3 Monate her #94717

  • Teddian
  • Teddians Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 14
  • Karma: 0
Dammit, and I went over them so many times :)

I did what you suggested, new question, quick add, copied the question and changed it into an array and an array(text). This time, on the first case it just showed me all the answers of the 2nd question, like there was no filter option (even though the hidden was selected and the filter was set). When I changed it into array(text) more things happened. First, the 63rd answer option dissapeared and 305 was put into its place. Seems there is some conflict with changing the question type and answer options. Then it also did not filter the answers :(
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.159 Sekunden
Donation Image