Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Numerical Input range error message appears when min > 0

Numerical Input range error message appears when min > 0 1 Jahr 9 Monate her #90762

  • jessicar64
  • jessicar64s Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 8
  • Karma: 0
I searched the forum and bug tracker, and can't find this discussed before, though I'm sure many people have run into it. I apologize if this has been answered before.

I am using Version 1.92+ Build 120822.

In a "Numerical input" type question, if I set the "Minimum value" to any number other than 0 and the "Maximum value" to any number greater than that, then the numerical input cell is highlighted pink and the error message appears that, for example, "Each answer must be between 50 and 90" even before the respondent has a chance to type anything.

See screen shot below. Also attached is a test survey where this happens.


Dateianhang:

Dateiname: limesurvey_survey_57253.lss
Dateigröße: 21 KB
Letzte Änderung: 1 Jahr 9 Monate her von jessicar64.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Numerical Input range error message appears when min > 0 1 Jahr 9 Monate her #90789

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 6451
  • Dank erhalten: 844
  • Karma: 249
1.92+ Build 120822 is not the last 1.92 version, maybe a bug corrected in 120919
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Re: Numerical Input range error message appears when min > 0 1 Jahr 9 Monate her #91026

  • jessicar64
  • jessicar64s Avatar
  • OFFLINE
  • Fresh Lemon
  • Beiträge: 8
  • Karma: 0
I upgraded to build 120919 of 1.92+. Also installed the current version (as of last night) of 2.0 on a local machine and tried it there. Still getting the same error. In fact, we also see this error with the EM demo surveys.

Specifically, I copied this demo survey: ls2_em_tailoring.lss
and tried it in version 1.92 builds 120822 and 120919, and in version 2.0. Tried it in Chrome, IE, and Firefox on at least seven different PCs and an iPad. (One machine, 3 browsers for 2.0; multiple machines and browsers for 1.92). Each time I see this:



Which does not look like the screen shot on this page: docs.limesurvey.org/Expression+Manager+Sample+Surveys

I made no changes to the demo survey, just ran it as is.

Any idea what is going on or how to eliminate the pink error messages that appear before the respondent enters anything?

Thanks!
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Moderatoren: ITEd
Ladezeit der Seite: 0.119 Sekunden
Donation Image